package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+?\t.\tnontraditional field\tText\t2,319\tInterview 1\.txt$`)
var str = `2 a nontraditional field Text 2,319 Interview 1.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}