re = /^\d+?\t.\tnontraditional field\tText\t2,319\tInterview 1\.txt$/m
str = '2 a nontraditional field Text 2,319 Interview 1.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end