// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+?\t.\tnontraditional field\tText\t2,319\tInterview 1\.txt$").unwrap();
let string = "2 a nontraditional field Text 2,319 Interview 1.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}