const regex = /^\d+?\t.\tnontraditional field\tText\t2,319\tInterview 1\.txt$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+?\\t.\\tnontraditional field\\tText\\t2,319\\tInterview 1\\.txt$', 'gm')
const str = `2 a nontraditional field Text 2,319 Interview 1.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}