$re = '/^\d+?\t.\tnontraditional field\tText\t2,319\tInterview 1\.txt$/m';
$str = '2 a nontraditional field Text 2,319 Interview 1.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);