# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[][]/`$0/gi;t' <<< "servername.example.com(0-0)[OS].vhdx"