import Foundation
let pattern = #"[][]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"servername.example.com(0-0)[OS].vhdx"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"`$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)