package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[][]`)
var str = `servername.example.com(0-0)[OS].vhdx`
var substitution = "`$0"
fmt.Println(re.ReplaceAllString(str, substitution))
}