using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[][]";
string substitution = @"`$0";
string input = @"servername.example.com(0-0)[OS].vhdx";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}