use strict;
my $str = 'servername.example.com(0-0)[OS].vhdx';
my $regex = qr`[][]`ip;
my $subst = '`$0';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";