#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\p{Han}|[^а-яa-zА-ЯA-Z]+$"
Local $sString = "你妳好12312" & @CRLF & _
"第三方" & @CRLF & _
"阿伱斯顿АквsSукпП" & @CRLF & _
"阿斯Фа фФвSsыв" & @CRLF & _
"Yury1" & @CRLF & _
"S1f你好jd" & @CRLF & _
"S1f 你好jd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")