const regex = /\p{Han}|[^а-яa-zА-ЯA-Z]+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\p{Han}|[^а-яa-zА-ЯA-Z]+$', 'g')
const str = `你妳好12312
第三方
阿伱斯顿АквsSукпП
阿斯Фа фФвSsыв
Yury1
S1f你好jd
S1f 你好jd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}