re = /\p{Han}|[^а-яa-zА-ЯA-Z]+$/
str = '你妳好12312
第三方
阿伱斯顿АквsSукпП
阿斯Фа фФвSsыв
Yury1
S1f你好jd
S1f 你好jd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end