package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\p{Han}|[^а-яa-zА-ЯA-Z]+$`)
var str = `你妳好12312
第三方
阿伱斯顿АквsSукпП
阿斯Фа фФвSsыв
Yury1
S1f你好jd
S1f 你好jd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}