# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+)x\d+\.jpg$/$0 $1/gm;t' <<< "1000x1000.jpg
750x750.jpg
1000x750.jpg
750x1000.jpg"