using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)x\d+\.jpg$";
string substitution = @"$0 $1";
string input = @"1000x1000.jpg
750x750.jpg
1000x750.jpg
750x1000.jpg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}