const regex = /^(\d+)x\d+\.jpg$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)x\\d+\\.jpg$', 'gm')
const str = `1000x1000.jpg
750x750.jpg
1000x750.jpg
750x1000.jpg`;
const subst = `$0 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);