// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+)x\d+\.jpg$").unwrap();
let string = "1000x1000.jpg
750x750.jpg
1000x750.jpg
750x1000.jpg";
let substitution = "$0 $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}