re = /^(\d+)x\d+\.jpg$/m
str = '1000x1000.jpg
750x750.jpg
1000x750.jpg
750x1000.jpg'
subst = '$0 $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result