#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Объем---([0-9]+).([0-9]+)"
Local $sString = "Краски---Страна производства---США|Краски---Производитель---Sherwin Williams|Краски---Тип---Интерьерная краска|Краски---Объем---0.95|Краски---Основа---На водной основе|Краски---Способ нанесения---кисть-валик-краскопульт|Краски---Расход---8-10 кв.м/л|Краски---Текстура ▹ степень блеска---Сатин|Краски---Помещение/поверхности---Интерьерная краска"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")