import Foundation
let pattern = #"Объем---([0-9]+).([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Краски---Страна производства---США|Краски---Производитель---Sherwin Williams|Краски---Тип---Интерьерная краска|Краски---Объем---0.95|Краски---Основа---На водной основе|Краски---Способ нанесения---кисть-валик-краскопульт|Краски---Расход---8-10 кв.м/л|Краски---Текстура ▹ степень блеска---Сатин|Краски---Помещение/поверхности---Интерьерная краска"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)