use strict;
my $str = 'Краски---Страна производства---США|Краски---Производитель---Sherwin Williams|Краски---Тип---Интерьерная краска|Краски---Объем---0.95|Краски---Основа---На водной основе|Краски---Способ нанесения---кисть-валик-краскопульт|Краски---Расход---8-10 кв.м/л|Краски---Текстура ▹ степень блеска---Сатин|Краски---Помещение/поверхности---Интерьерная краска';
my $regex = qr/Объем---([0-9]+).([0-9]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}