re = /Объем---([0-9]+).([0-9]+)/m
str = 'Краски---Страна производства---США|Краски---Производитель---Sherwin Williams|Краски---Тип---Интерьерная краска|Краски---Объем---0.95|Краски---Основа---На водной основе|Краски---Способ нанесения---кисть-валик-краскопульт|Краски---Расход---8-10 кв.м/л|Краски---Текстура ▹ степень блеска---Сатин|Краски---Помещение/поверхности---Интерьерная краска'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end