import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Объем---([0-9]+).([0-9]+)";
final String string = "Краски---Страна производства---США|Краски---Производитель---Sherwin Williams|Краски---Тип---Интерьерная краска|Краски---Объем---0.95|Краски---Основа---На водной основе|Краски---Способ нанесения---кисть-валик-краскопульт|Краски---Расход---8-10 кв.м/л|Краски---Текстура ▹ степень блеска---Сатин|Краски---Помещение/поверхности---Интерьерная краска";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}