import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "The following dependencies in Dependencies have newer versions:\\s+([^:]+:[^: ]+).*?([0-9]+(?:.[0-9]+)+) -> ([0-9]+(?:.[0-9]+)+)";
final String string = "The following dependencies in Dependencies have newer versions:\n"
+ " org.apache.maven:maven-plugin-api ..................... 3.6.0 -> 3.6.1\n"
+ " org.apache.maven.plugin-tools:maven-plugin-annotations ...\n"
+ " 3.5.2 -> 3.6.0\n"
+ " org.codehaus.groovy:groovy-all ................. 2.5.7 -> 3.0.0-beta-2\n\n"
+ "Project does not have a parent.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}