// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)The following dependencies in Dependencies have newer versions:\s+([^:]+:[^: ]+).*?([0-9]+(?:.[0-9]+)+) -> ([0-9]+(?:.[0-9]+)+)").unwrap();
let string = "The following dependencies in Dependencies have newer versions:
org.apache.maven:maven-plugin-api ..................... 3.6.0 -> 3.6.1
org.apache.maven.plugin-tools:maven-plugin-annotations ...
3.5.2 -> 3.6.0
org.codehaus.groovy:groovy-all ................. 2.5.7 -> 3.0.0-beta-2
Project does not have a parent.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}