re = /The following dependencies in Dependencies have newer versions:\s+([^:]+:[^: ]+).*?([0-9]+(?:.[0-9]+)+) -> ([0-9]+(?:.[0-9]+)+)/m
str = 'The following dependencies in Dependencies have newer versions:
org.apache.maven:maven-plugin-api ..................... 3.6.0 -> 3.6.1
org.apache.maven.plugin-tools:maven-plugin-annotations ...
3.5.2 -> 3.6.0
org.codehaus.groovy:groovy-all ................. 2.5.7 -> 3.0.0-beta-2
Project does not have a parent.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end