use strict;
my $str = 'The following dependencies in Dependencies have newer versions:
org.apache.maven:maven-plugin-api ..................... 3.6.0 -> 3.6.1
org.apache.maven.plugin-tools:maven-plugin-annotations ...
3.5.2 -> 3.6.0
org.codehaus.groovy:groovy-all ................. 2.5.7 -> 3.0.0-beta-2
Project does not have a parent.';
my $regex = qr/The following dependencies in Dependencies have newer versions:\s+([^:]+:[^: ]+).*?([0-9]+(?:.[0-9]+)+) -> ([0-9]+(?:.[0-9]+)+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}