#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)a.*t"
Local $sString = "# Greedy, Lazy, and Possessive quantifier" & @CRLF & _
"" & @CRLF & _
"Match: " & @CRLF & _
" /" & @CRLF & _
" a # Match a" & @CRLF & _
" .* # Match any character" & @CRLF & _
" t # Match t" & @CRLF & _
" /" & @CRLF & _
"" & @CRLF & _
"greedy can be dangerous at times" & @CRLF & _
"" & @CRLF & _
"r re regex" & @CRLF & _
"" & @CRLF & _
"tttt aaaaa aattaatatatatttt atttatt ttat" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")