package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a.*t`)
var str = `# Greedy, Lazy, and Possessive quantifier
Match:
/
a # Match a
.* # Match any character
t # Match t
/
greedy can be dangerous at times
r re regex
tttt aaaaa aattaatatatatttt atttatt ttat
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}