$re = '/a.*t/m';
$str = '# Greedy, Lazy, and Possessive quantifier
Match:
/
a # Match a
.* # Match any character
t # Match t
/
greedy can be dangerous at times
r re regex
tttt aaaaa aattaatatatatttt atttatt ttat
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);