re = /a.*t/m
str = '# Greedy, Lazy, and Possessive quantifier
Match:
/
a # Match a
.* # Match any character
t # Match t
/
greedy can be dangerous at times
r re regex
tttt aaaaa aattaatatatatttt atttatt ttat
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end