import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a.*t";
final String string = "# Greedy, Lazy, and Possessive quantifier\n\n"
+ "Match: \n"
+ " /\n"
+ " a # Match a\n"
+ " .* # Match any character\n"
+ " t # Match t\n"
+ " /\n\n"
+ "greedy can be dangerous at times\n\n"
+ "r re regex\n\n"
+ "tttt aaaaa aattaatatatatttt atttatt ttat\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}