using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""steps"":)[^,]+";
string input = @"{""summaryId"":""x436a218-61703d00-15180-6"",""calendarDate"":""2021-10-21"",""activityType"":""WALKING"",""activeKilocalories"":119,""bmrKilocalories"":2283,""steps"":3972,""distanceInMeters"":2919.0,""durationInSeconds"":86400,""activeTimeInSeconds"":2786,""startTimeInSeconds"":1634745600,""startTimeOffsetInSeconds"":28800,""moderateIntensityDurationInSeconds"":0,""vigorousIntensityDurationInSeconds"":0,""stepsGoal"":7500,""intensityDurationGoalInSeconds"":9000,""floorsClimbedGoal"":10}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}