import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\"steps\":)[^,]+";
final String string = "{\"summaryId\":\"x436a218-61703d00-15180-6\",\"calendarDate\":\"2021-10-21\",\"activityType\":\"WALKING\",\"activeKilocalories\":119,\"bmrKilocalories\":2283,\"steps\":3972,\"distanceInMeters\":2919.0,\"durationInSeconds\":86400,\"activeTimeInSeconds\":2786,\"startTimeInSeconds\":1634745600,\"startTimeOffsetInSeconds\":28800,\"moderateIntensityDurationInSeconds\":0,\"vigorousIntensityDurationInSeconds\":0,\"stepsGoal\":7500,\"intensityDurationGoalInSeconds\":9000,\"floorsClimbedGoal\":10}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}