const regex = /(?<="steps":)[^,]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="steps":)[^,]+', 'gm')
const str = `{"summaryId":"x436a218-61703d00-15180-6","calendarDate":"2021-10-21","activityType":"WALKING","activeKilocalories":119,"bmrKilocalories":2283,"steps":3972,"distanceInMeters":2919.0,"durationInSeconds":86400,"activeTimeInSeconds":2786,"startTimeInSeconds":1634745600,"startTimeOffsetInSeconds":28800,"moderateIntensityDurationInSeconds":0,"vigorousIntensityDurationInSeconds":0,"stepsGoal":7500,"intensityDurationGoalInSeconds":9000,"floorsClimbedGoal":10}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}