$re = '/(?<="steps":)[^,]+/m';
$str = '{"summaryId":"x436a218-61703d00-15180-6","calendarDate":"2021-10-21","activityType":"WALKING","activeKilocalories":119,"bmrKilocalories":2283,"steps":3972,"distanceInMeters":2919.0,"durationInSeconds":86400,"activeTimeInSeconds":2786,"startTimeInSeconds":1634745600,"startTimeOffsetInSeconds":28800,"moderateIntensityDurationInSeconds":0,"vigorousIntensityDurationInSeconds":0,"stepsGoal":7500,"intensityDurationGoalInSeconds":9000,"floorsClimbedGoal":10}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);