#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=name.\s).*"
Local $sString = "Hi,find the below information." & @CRLF & _
"It involves all the info about student." & @CRLF & _
"Basic and personal details and educational details are also included for additional information." & @CRLF & _
"" & @CRLF & _
"What is name? Sri" & @CRLF & _
"Is student btech or BE? B.tech" & @CRLF & _
"" & @CRLF & _
"Mobile number of student: xxxxxxxxxx,yyyyyyyyyy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")