using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=name.\s).*";
string input = @"Hi,find the below information.
It involves all the info about student.
Basic and personal details and educational details are also included for additional information.
What is name? Sri
Is student btech or BE? B.tech
Mobile number of student: xxxxxxxxxx,yyyyyyyyyy";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}