import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=name.\\s).*";
final String string = "Hi,find the below information.\n"
+ "It involves all the info about student.\n"
+ "Basic and personal details and educational details are also included for additional information.\n\n"
+ "What is name? Sri\n"
+ "Is student btech or BE? B.tech\n\n"
+ "Mobile number of student: xxxxxxxxxx,yyyyyyyyyy";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}