re = /(?<=name.\s).*/m
str = 'Hi,find the below information.
It involves all the info about student.
Basic and personal details and educational details are also included for additional information.
What is name? Sri
Is student btech or BE? B.tech
Mobile number of student: xxxxxxxxxx,yyyyyyyyyy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end