const regex = /(?<=name.\s).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=name.\\s).*', 'gm')
const str = `Hi,find the below information.
It involves all the info about student.
Basic and personal details and educational details are also included for additional information.
What is name? Sri
Is student btech or BE? B.tech
Mobile number of student: xxxxxxxxxx,yyyyyyyyyy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}