#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:-\w+-)*linear-gradient\((?:.*?(?<=top|bottom|left|right|deg)\s*,\s*)*"
Local $sString = "-webkit-linear-gradient(top , rgb(243, 231, 231), rgba(12, 0, 0, 0.48));" & @CRLF & _
"-moz-linear-gradient(90deg , hsl(0, 80%, 70%), #bada55) " & @CRLF & _
"-o-linear-gradient(bottom, hsl(0, 80%, 70%), #bada55) ; " & @CRLF & _
"linear-gradient(135deg , red, red 60%, blue) ;" & @CRLF & _
"" & @CRLF & _
"linear-gradient(yellow, blue 20%, #0f0);" & @CRLF & _
"" & @CRLF & _
"linear-gradient( to left top, blue, green 40%, red ); " & @CRLF & _
"linear-gradient(to top left , red, orange, yellow, green, blue, indigo, violet) ; " & @CRLF & _
"linear-gradient(to bottom right , red, rgba(255, 0, 0, 0)); " & @CRLF & _
"linear-gradient(right top to left bottom, red, rgb(255, 0, 0));" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")