re = /^(?:-\w+-)*linear-gradient\((?:.*?(?<=top|bottom|left|right|deg)\s*,\s*)*/m
str = '-webkit-linear-gradient(top , rgb(243, 231, 231), rgba(12, 0, 0, 0.48));
-moz-linear-gradient(90deg , hsl(0, 80%, 70%), #bada55)
-o-linear-gradient(bottom, hsl(0, 80%, 70%), #bada55) ;
linear-gradient(135deg , red, red 60%, blue) ;
linear-gradient(yellow, blue 20%, #0f0);
linear-gradient( to left top, blue, green 40%, red );
linear-gradient(to top left , red, orange, yellow, green, blue, indigo, violet) ;
linear-gradient(to bottom right , red, rgba(255, 0, 0, 0));
linear-gradient(right top to left bottom, red, rgb(255, 0, 0));
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end