using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:-\w+-)*linear-gradient\((?:.*?(?<=top|bottom|left|right|deg)\s*,\s*)*";
string input = @"-webkit-linear-gradient(top , rgb(243, 231, 231), rgba(12, 0, 0, 0.48));
-moz-linear-gradient(90deg , hsl(0, 80%, 70%), #bada55)
-o-linear-gradient(bottom, hsl(0, 80%, 70%), #bada55) ;
linear-gradient(135deg , red, red 60%, blue) ;
linear-gradient(yellow, blue 20%, #0f0);
linear-gradient( to left top, blue, green 40%, red );
linear-gradient(to top left , red, orange, yellow, green, blue, indigo, violet) ;
linear-gradient(to bottom right , red, rgba(255, 0, 0, 0));
linear-gradient(right top to left bottom, red, rgb(255, 0, 0));
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}