import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:-\\w+-)*linear-gradient\\((?:.*?(?<=top|bottom|left|right|deg)\\s*,\\s*)*";
final String string = "-webkit-linear-gradient(top , rgb(243, 231, 231), rgba(12, 0, 0, 0.48));\n"
+ "-moz-linear-gradient(90deg , hsl(0, 80%, 70%), #bada55) \n"
+ "-o-linear-gradient(bottom, hsl(0, 80%, 70%), #bada55) ; \n"
+ "linear-gradient(135deg , red, red 60%, blue) ;\n\n"
+ "linear-gradient(yellow, blue 20%, #0f0);\n\n"
+ "linear-gradient( to left top, blue, green 40%, red ); \n"
+ "linear-gradient(to top left , red, orange, yellow, green, blue, indigo, violet) ; \n"
+ "linear-gradient(to bottom right , red, rgba(255, 0, 0, 0)); \n"
+ "linear-gradient(right top to left bottom, red, rgb(255, 0, 0));\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}