use strict;
my $str = '-webkit-linear-gradient(top , rgb(243, 231, 231), rgba(12, 0, 0, 0.48));
-moz-linear-gradient(90deg , hsl(0, 80%, 70%), #bada55)
-o-linear-gradient(bottom, hsl(0, 80%, 70%), #bada55) ;
linear-gradient(135deg , red, red 60%, blue) ;
linear-gradient(yellow, blue 20%, #0f0);
linear-gradient( to left top, blue, green 40%, red );
linear-gradient(to top left , red, orange, yellow, green, blue, indigo, violet) ;
linear-gradient(to bottom right , red, rgba(255, 0, 0, 0));
linear-gradient(right top to left bottom, red, rgb(255, 0, 0));
';
my $regex = qr/^(?:-\w+-)*linear-gradient\((?:.*?(?<=top|bottom|left|right|deg)\s*,\s*)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}