using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"revenue.{0,10}?\s(\d+(?:[.,%]\d+)*\s*\w*)";
string input = @"The company has a revenue of 2.7 Mio.
The company creates growing revenues and employs more than 25 employees.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}