// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)revenue.{0,10}?\s(\d+(?:[.,%]\d+)*\s*\w*)").unwrap();
let string = "The company has a revenue of 2.7 Mio.
The company creates growing revenues and employs more than 25 employees.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}