import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "revenue.{0,10}?\\s(\\d+(?:[.,%]\\d+)*\\s*\\w*)";
final String string = "The company has a revenue of 2.7 Mio.\n"
+ "The company creates growing revenues and employs more than 25 employees.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}